This project is archived and is in readonly mode.

#227 ✓resolved

Wrong option naming in Asset

Reported by DiegoMax | January 4th, 2010 @ 12:55 AM | in

Hi there, i think some options in Asset should be renamed to follow mootools naming conventions.

From the Asset.Images docs for example

WARNING: DO NOT use addEvent for load/error/abort on the returned element, give them as onload/onerror/onabort in the properties argument.

That is fine, but it should be onLoad, onError and onAbort instead.
Same goes for Asset.javascript onload property, which should (imho) be renamed to 'onLoad'.


Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

The MooTools Extensions

People watching this ticket