This project is archived and is in readonly mode.

#265 ✓resolved
Liam Gladdy

Tips addEvent('hide') doesn't work

Reported by Liam Gladdy | February 16th, 2010 @ 10:42 AM | in 1.2.5.1

Hey guys, The following documented code (from docs.mootools.net) doesn't work in mootools-1.2.4.4:

var tooltips = new Tips('.tip');
tooltips.addEvent('hide', function(tip, el){
tip.fade('out'); });

The custom hide event is fired, but the default hide event is still fired (so the fade out doesn't work, as its always set to display:none)

If you set the hide event as part of the instance creation then it's fine.

Comments and changes to this ticket

  • fakedarren

    fakedarren February 16th, 2010 @ 01:15 PM

    • State changed from “new” to “open”
    • Assigned user set to “fakedarren”
    • Milestone set to 1.2.5.2

    We'll update the docs soon.

  • csuwldcat

    csuwldcat September 4th, 2010 @ 10:56 PM

    • Milestone order changed from “0” to “0”

    The other default show/hide events are fired because the events you added are being fired after the default events. To achieve this behavior, first remove the default events you would like to override, TipsInstance.removeEvents('show') then add your own events as you have in this ticket.

    I am making a change to the Docs to explain this.

  • csuwldcat

    csuwldcat September 4th, 2010 @ 11:29 PM

    Change pushed to repo, please close this ticket.

  • Arian

    Arian September 5th, 2010 @ 12:47 AM

    • State changed from “open” to “resolved”
  • Aaron Newton

    Aaron Newton October 12th, 2010 @ 04:09 AM

    • Milestone changed from 1.2.5.2 to 1.2.5.1
    • Milestone order changed from “6” to “0”

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

The MooTools Extensions

Tags

Pages