This project is archived and is in readonly mode.

#511 ✓invalid
joe

unknown pseudo:contains

Reported by joe | February 14th, 2011 @ 01:11 PM

using this:

$$('#theTable td:contains("'+taaaa+'")').setStyle('color', myColor[colNum]);

brings the following error in Firefox 3.6

unknown pseudoclass or pseudoelemnt 'contains'

mootools-more-1.3.0.1-nocompat-yc.js

Comments and changes to this ticket

  • Arian

    Arian February 14th, 2011 @ 08:18 PM

    http://jsfiddle.net/4sSZw/1/ seems to work fine in Firefox 3.6.

    What is in the variable taaaa, could you update the jsfiddle with your case where it fails?

  • joe

    joe February 14th, 2011 @ 09:05 PM

    if have with your jsfiddle example this error message in firebug:

    Unbekannte Pseudoklasse oder Pseudoelement 'contains'. (unknown pseudoclass or pseudoelement)
    return new ActiveXObject('ShockwaveFl...kwaveFlash').GetVariable('$version');
    mootoo...t-nc.js (Zeile 1266)

    I do not have flash installed. Does mootools need flash?

  • Arian

    Arian February 14th, 2011 @ 09:13 PM

    Really? It works fine for me in Firefox 3.6. You just run my jsfiddle and you get that error in firebug or something?

    And fortunately MooTools does not need flash. Which version of Firefox 3.6 are you using?

  • joe

    joe February 14th, 2011 @ 09:46 PM

    firefox 3.6.13 and firebug 1.6.0

  • JacobThornton

    JacobThornton February 23rd, 2011 @ 07:56 PM

    I also have firefox 3.6.13 and firebug 1.6, but see no problems here. Maybe you have some other weird plugin installed which is messing your stuff up?

  • David Walsh

    David Walsh June 5th, 2011 @ 07:33 PM

    • State changed from “new” to “invalid”

    I can't duplicate this either. Closing.

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

The MooTools Extensions

Pages