This project is archived and is in readonly mode.

#1008 ✓wontfix
Thomas Aylott

Verify Dependency map compatibility from 1.2.5 to 1.3.0

Reported by Thomas Aylott | September 16th, 2010 @ 05:04 PM | in 1.3.0 rc2 (closed)

Make sure that Packager and Depender can use 1.3+1.2-compat as a drop-in replacement for 1.2.

Comments and changes to this ticket

  • Thomas Aylott

    Thomas Aylott September 24th, 2010 @ 04:40 AM

    • State changed from “open” to “wontfix”

    This was over-ruled on IRC from both kamicane and cpojer.

    'Compat provides' for 1.2 will not be included in 1.3.

    There was some disagreement from people who believe that this is a breaking change that removes our ability for 1.3 to be a 'drop in replacement' for 1.2.

    The few people who have been using the provides system in 1.2x must manually update their requires to support 1.3. 1.3 will not be a drop-in replacement.

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

People watching this ticket

Pages