This project is archived and is in readonly mode.

#1058 ✓resolved
philfreo

Mootools IE6-7 1.3 bug

Reported by philfreo | October 29th, 2010 @ 08:45 PM | in 1.3.1 (closed)

There is some additional discussion around this bug on the mailing list:
http://groups.google.com/group/mootools-users/browse_thread/thread/...

I've found a pretty bad bug in Mootools 1.3 that didn't exist in 1.2, that
affects IE6-7 users.

I've mentioned this on IRC and not everybody is able to reproduce it, but I
have had several people be able to reproduce it on different computers
running IE6-7, and it has been the root cause of a lot of user complaints
recently on Quizlet.com.

The follow pages "work" if you get an alert('sauce') popup. They don't work
if you get a JS error. (NOTE: Only IE6-7 are affected).

Simplified snippet of the bug:
On 1.2 (this work's fine, alert() msg) -> http://quizlet.com/moo2.htm
On 1.3 (this is broken in IE6-7, js error, no alert()) -> http://quizlet.com/moo3.htm

Screenshots from browsershots.org:
On 1.3 (IE6, broken) -> http://browsershots.org/screenshots/8dac1f27fb13eb66ae567b4cbe86bb1f
On 1.3 (IE7, broken) -> http://browsershots.org/screenshots/5750950ec55a32673d4595bdabc9ffbf
On 1.2 (IE6, works) -> http://browsershots.org/screenshots/ca52437ac6722955a23b7d729f994ce7
On 1.2 (IE7, works) -> http://browsershots.org/screenshots/f9870b41a948a5c6521289e40e047c13

There's definitely a problem... (I've reproduced it on several different real PCs with native IE7 installations (IE 7.0.5730.13IC and IE 7.0.5730.13.xpsp.080413-2111), as well as a couple different virtual machines with IE6).

Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

Referenced by

Pages