This project is archived and is in readonly mode.

#246 ✓invalid
David Baltusavich

Swiff not working at all???

Reported by David Baltusavich | July 21st, 2008 @ 06:47 PM | in 2.0 (closed)

I can't seem to get Swiff to work at all. I just downloaded core and more from the builder, so they are both completely current.

I'm using Firefox 3 (latest) and Firebug (latest).

My example goes like this:

1) I've confirmed that the flash file exists and it reachable at a given url (var s) and that the window Object exposes __flash__ functions as one might expect when the SWF is opened in it's own tab.

2) I've attempted to load the Flash using a bare-bones Swiff instance:

var obj = new Swiff(s, { container: new Element('div').injectInside(document.body), events: { onLoad: alert.pass('onload'), load: alert.pass('load') } } );

3) NOTHING HAPPENS. The SWF does not even load. Once, randomly, the SWF did load, but the remote() method still returned an error: "obj.CallFunction not defined", where obj was the the Swiff instance.

4) The SWF is on the same domain as the calling page, although in a different folder.

5) I use the full URL (including domain, protocol, etc) rather than a relative path (again, the URL works when entered separately)

It doesn't matter if I preload the Element for the container or if I define it in-line.

Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

Pages