This project is archived and is in readonly mode.

#405 ✓resolved
Tom Occhino

Request.HTML Problems

Reported by Tom Occhino | October 6th, 2008 @ 08:26 AM | in 1.3.0 rc2 (closed)

  • currently only works on XML documents (XHTML)
  • breaks when there are comments in the response
  • should not try to create and adopt nodes for the update option
  • should use the new set('html') property

Comments and changes to this ticket

  • Tom Occhino

    Tom Occhino October 6th, 2008 @ 08:26 AM

    • State changed from “new” to “open”
  • Jan Kassens

    Jan Kassens November 8th, 2008 @ 06:22 PM

    • Tag set to enhancement, request.html

    stripts from the response w/o including the script. probably String.stripScripts should handle that?

  • Francois

    Francois December 3rd, 2008 @ 07:44 PM

    • Tag changed from enhancement, request.html to ajax, blocking, enhancement, entity, request.html, webkit

    Same problem, and really annoying (no webkit browsers works). Anyway to push this fix git repo ?

    http://www.mooforum.net/solution...

    or as mentioned above, add a method to set up content type.

  • Greg Houston

    Greg Houston March 9th, 2009 @ 04:33 PM

    Parsing the response text as XML also causes a couple issues in Internet Explorer 6 and 7:

    1.Some whitespace is preserved as if the content were in pre tags. This issue does not exist in IE8 RC1 however, just 6 and 7.

    1. Tables are not displayed unless the XML is invalid. I haven't checked this in IE8.
  • nelero

    nelero August 29th, 2009 @ 11:24 PM

    Same problem tested with 1.2.2 and 1.2.3 on Firefox 3.5.2 and Opera (i haven't tested on others browsers)

    If requested html is only partial html code and contains entities like é or  , then Request and Request.HTML fail.
    However, it's a real need since you can load only parts of UI

    Is this still due to the clone function ?

    Thanks

  • Thomas Aylott
  • Christoph Pojer

    Christoph Pojer September 3rd, 2010 @ 01:15 PM

    • Assigned user changed from “Tom Occhino” to “Fábio M. Costa”
    • Milestone order changed from “0” to “0”
  • Fábio M. Costa

    Fábio M. Costa September 6th, 2010 @ 09:26 PM

    • Milestone set to 1.3.0 rc2
    • State changed from “open” to “resolved”
    • Milestone order changed from “15” to “0”
    • currently only works on XML documents (XHTML)

    We don't parse the text response using 'text/xml' anymore, so this is working just fine.

    • breaks when there are comments in the response

    With Slick and by not parsing the text response this is not a problem anymore.

    • should not try to create and adopt nodes for the update option

    Same here.

    • should use the new set('html') property

    It still does.

    I'm adding some new specs too so everything is just fine.

    Specs: http://github.com/fabiomcosta/mootools-core-specs/compare/669e4aa.....

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

Referenced by

Pages