This project is archived and is in readonly mode.

#58 ✓resolved
Thomas Aylott

Overflow element incorrect/inconsistent position

Reported by Thomas Aylott | May 28th, 2008 @ 10:06 AM | in 1.3.0 rc2 (closed)

Originally posted on Trac by dc

Original Trac Ticket

Description

This is an issue that I encounter only with Safari & IE. (i assume all version) Firefox seems to give me the best results. When using a overflow:hidden element, I cannot get a consistent value for position x/y

I've set up 2 test links using two different version of mootools and both cause inconsistencies. http://www.hdxi.com/overflow/?js... http://www.hdxi.com/overflow/?js=mootools-beta-1.2b2

In Safari 3 for xp, it could be a browser bug. If you first load / hard refresh the page, you'll get a bad position. However, if you just click on the address bar, and press enter to do a simple refresh, the position is correct. Something with the DOM not fully loaded.

Browsers affected:

Safari 3 beta

IE 6

Trac Attachments

Trac Comments

Comments and changes to this ticket

  • fakedarren

    fakedarren February 8th, 2010 @ 02:37 PM

    • State changed from “new” to “open”
    • Tag set to defect
    • Assigned user changed from “Valerio” to “fakedarren”
    • Milestone changed from 2.0 to 1.3.0 rc2

    I hope this has been resolved by now. But will test before closing.

  • fakedarren

    fakedarren February 14th, 2010 @ 04:10 PM

    • State changed from “open” to “resolved”

    Bah. Closing. Element.Measure from -more for this

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

People watching this ticket

Tags

Pages