This project is archived and is in readonly mode.

#760 ✓invalid
Ulrich Petri

Wrong Trident version numbers

Reported by Ulrich Petri | October 6th, 2009 @ 06:39 PM | in 2.0 (closed)

Mootools uses engine names and versions to identify browsers.
As it stands now IE6 is identified as trident4 and IE7 as trident5.

But according to Trident @ Wikipedia and MSDN infact IE8 uses Trident 4, not IE6.

This should be fixed.

Comments and changes to this ticket

  • Scott Kyle

    Scott Kyle October 8th, 2009 @ 06:53 PM

    • State changed from “new” to “invalid”

    There was some misinformation that spread on the web equating ie6 = trident4 and ie7 = trident5, that led to this versioning convention, which in fact is incorrect as you've mentioned. Unfortunately, we can't change this without breaking compatibility, but 2.0 will correct this by using user agent detection rather than engine detection.

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

People watching this ticket

Pages