This project is archived and is in readonly mode.

#924 ✓duplicate
Oskar Krawczyk

1.3b2 lost compatibility with mootools-more (1.2.4.4)

Reported by Oskar Krawczyk | June 7th, 2010 @ 11:42 AM

Hey, compatibility was working cool with 1.3b1.1, but replacing the beta with b2 throws the following error:

    this.previous is not a function
    [Break on this error] this.previous(options);

This happens in the Spinner class:

initialize: function(options){
    this._send = this.send;
    this.send = function(options){
        if (this.spinner) this.spinner.chain(this._send.bind(this, options)).show();
        else this._send(options);
        return this;
    };
    this.previous(options); // <-- This
    var update = document.id(this.options.spinnerTarget) || document.id(this.options.update);
    if (this.options.useSpinner && update) {
        this.spinner = update.get('spinner', this.options.spinnerOptions);
        ['onComplete', 'onException', 'onCancel'].each(function(event){
        this.addEvent(event, this.spinner.hide.bind(this.spinner));
    }, this);
}

Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

Pages