This project is archived and is in readonly mode.

#935 ✓resolved
Michael Ficarra

Element.set(`opacity`) spec in mootools-core-specs fails on Chrome/Linux

Reported by Michael Ficarra | June 21st, 2010 @ 07:44 PM | in 1.3.0 rc2 (closed)

A recent pull from Fábio M. Costa's fork (the most recent commit to mootools-core master) has caused the spec labeled "Element.set opacity" to fail on Chrome 5.0.375.70 on Fedora 13. I have not been able to verify other distributions, but it seems to only apply to Chrome/Linux. The test labeled "should return the opacity of an Element" fails with the error message "actual value: 1 should be: 0.4 at undefined, line undefined". This is the only test that fails in the entire mootools-core-specs test suite. Firefox 3.6.3 on the same platform passes with a score of 100%.

The jsFiddle at http://jsfiddle.net/vzz5E/1/ shows an example of the problem. With the 1.3b2 that is included, everything works fine. If one could select a nightly 1.3 build, though, both tests would fail.

For reference, the original conversation with Fábio M. Costa regarding the issue:
http://github.com/michaelficarra/mootools-core/commit/b721f532c4a2d...

Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

People watching this ticket

Pages